Quiz Analytics Degraded Performance
Incident Report for Interact
Resolved
This incident has been resolved.
Posted Apr 04, 2019 - 08:00 PDT
Investigating
We are currently investigating an issue involving degraded performance of our analytics.
Posted Apr 04, 2019 - 03:00 PDT
This incident affected: Analytics (Quiz Analytics).