Dashboard Connectivity Issues
Incident Report for Interact
Resolved
This incident has been resolved by our third-party provider.
Posted Mar 10, 2021 - 16:45 PST
Identified
An issue related to users being unable to access their customer dashboard has been identified. A third-party hosting provider is currently experiencing some outages and may affect your ability to connect to the dashboard. We will continue to monitor the situation.
Posted Mar 10, 2021 - 16:42 PST
This incident affected: Dashboard.